北京联信永成科技有限公司主要供应华为交换机、华为路由器、思科防火墙、思科交换机、思科路由器、360防火墙、隔离网闸等产品!
热线电话:010-82927080      
  • 北京思科交换机
  • 北京华为交换机
  • 北京华为防火墙
  • 北京深信服安全行为管理
  • $
您所在的位置:首页 > 新闻中心  > 新闻中心
【必看】华为路由器配置对内网IP限速
来源:www.bjlxyc.cn 发布时间:2018年12月08日

北京华为路由器服务中心为难讲解路由器配置对内网IP限速:华为路由器配置对内网IP限速,RouterA部署在企业网的出口处,企业用户通过2个不同的网段连接到RouterA从而访问服务器222.1.1.1/24。现要求控制企业网内部用户192.168.10.0/24对服务器的访问,速率限制为64kbit/s。

图 配置基于内网IP进行限速的组网图 

北京华为路由器服务中心


操作步骤RouterA的配置

 

#
sysname RouterA
#
vlan batch 10 20 
#
acl number 3001  //配置编号为3001的编号型访问控制列表
rule 5 permit ip source 192.168.10.0 0.0.0.255  //配置规则5,允许源地址为192.168.10.0网段的报文通过
rule 10 permit ip source 192.168.20.0 0.0.0.255  //配置规则10,允许源地址为192.168.20.0网段的报文通过
acl number 3002  //配置编号为3002的编号型访问控制列表
rule 5 permit ip source 192.168.10.0 0.0.0.255  //配置规则5,允许源地址为192.168.10.0网段的报文通过
#
qos queue-profile limit  //创建队列模板limit
  queue 3 gts cir 64 cbs 1600  //配置队列3的承诺信息速率为64kbit/s
#
traffic classifier c1 operator or
if-match acl 3002  //配置流分类c1:匹配规则为ACL 3002
#
traffic behavior b1
remark local-precedence af3  //配置流行为b1:对匹配流分类的报文重标记本地优先级为AF3,不指定流行为为permit或deny时,默认为permit。
#
traffic policy p1
classifier c1 behavior b1  //配置流策略p1:绑定流分类c1与流行为b1
#
interface Vlanif10
ip address 192.168.10.1 255.255.255.0 
#
interface Vlanif20
ip address 192.168.20.1 255.255.255.0 
#
interface Ethernet2/0/0
port link-type trunk  //配置接口的链路类型为Trunk
port trunk allow-pass vlan 10 20  //配置Trunk类型接口加入vlan 10和vlan 20
traffic-policy p1 inbound  //在接口入方向上应用流策略p1
#
interface GigabitEthernet3/0/0
ip address 222.0.1.1 255.255.255.0 
qos queue-profile limit  //在接口上应用队列模板limit
nat outbound 3001  //在接口上对匹配ACL 3001的报文做NAT
#
ip route-static 0.0.0.0 0.0.0.0 222.0.1.2
#

验证配置结果 


# 执行display qos queue statistics interface gigabitethernet 3/0/0命令检查GE3/0/0接口上应用了队列模板limit后的报文统计信息,可以看到接口3号队列的输出速率被限制在规定范围内,队列满后,无法缓存的报文被丢弃。

配置注意事项


配置Switch与不同的网段用户对接的接口为Access类型接口,并将其加入对应VLAN。
配置Switch与RouterA对接的接口为Trunk类型接口,并加入对应VLAN。